Cum să faci downgrade la un pachet în Debian sau Ubuntu

Uneori mai fac şmecheria de a schimba repozitoriile în Ubuntu, în loc de hardy schimb în jaunty, asta pentru a instala versiunea mai nouă a unor programe. Din această cauză, uneori apar probleme, că se instalează dependinţe mai noi, şi când încerc deja să instalez vreo aplicaţie din repozitoriile lui hardy, sistemus spune că depinde de o versiune mai veche a unei dependinţe, şi nu poate instala.

Când apar asemenea probleme, trebuie să instalăm versiunea aceea veche. Iată cum:

$ apt-cache showpkg perl-base

(asta pentru pachetul perl-base).

va afişa următoarele:

Provides:
5.10.0-23 - perlapi-5.10.0 perl5-base libxsloader-perl libscalar-list-utils-perl
5.10.0-19 - perlapi-5.10.0 perl5-base libxsloader-perl libscalar-list-utils-perl

Să zicem că pe noi ne interesează versiunea 5.10.0-19. Facem următoarele:

$ sudo aptitude install perl-base=5.10.0-19

Vedeţi bine, am pus numele pachetului (perl-base), semnul egal (=) şi versiunea care mă interesează.

Anunțuri

Lasă un răspuns

Completează mai jos detaliile tale sau dă clic pe un icon pentru a te autentifica:

Logo WordPress.com

Comentezi folosind contul tău WordPress.com. Dezautentificare / Schimbă )

Poză Twitter

Comentezi folosind contul tău Twitter. Dezautentificare / Schimbă )

Fotografie Facebook

Comentezi folosind contul tău Facebook. Dezautentificare / Schimbă )

Fotografie Google+

Comentezi folosind contul tău Google+. Dezautentificare / Schimbă )

Conectare la %s

%d blogeri au apreciat asta: