How to install GIMP 2.6 on Ubuntu Hardy

As you know, GIMP (Gnu Image Manipulation Program) is a free and powerful raster image editor. Last week was the release of the stable 2.6 version. Among the improvements are windows centralisation (there’s only one window now, finally), and GEGL support.

I’ll explain the simplest way to install it on Ubuntu Hardy Heron. Follow these steps:

1. Add the unofficial getdeb repository into your /etc/apt/sources.list. Do:

$sudo gedit /etc/apt/sources.list (or instead of gedit you can use your favorite text editor, eg. nano, kwrite, kate, vim, emacs)

Now paste these two lines at the end of the opened file:

# Unofficial Getdeb repositories:

deb http://ubuntu.org.ua/ getdeb/

Save the document, and close it.

Now update with the command: $sudo apt-get update

2. Remove your current Gimp instalation, with the command:

$sudo apt-get purge gimp

3. (optional) Check which version of gimp is the first candidate for instalation:

$apt-cache policy gimp

4. If you see the version 2.6 of gimp present, install GIMP:

$sudo apt-get install gimp

Press „y”, and wait some time, for the instalation to finish.

5. Now, when you have GIMP installed, you should comment the getdeb repository in your /etc/apt/sources.list . Again do:

$sudo gedit /etc/apt/sources.list

and put a „#” at the beginning of the line „deb http://ubuntu.org.ua/ getdeb/” (that you inserted in the first step).

6. Enjoy yourself.

Gimp 2.6 screenshot on my machine

Gimp 2.6 screenshot on my machine

5 Comments

  1. Diana
    Posted 23 octombrie, 2008 at 11:40 am | Permalink | Răspunde

    Salut Sergiu 🙂
    Chiar vorbeam zilele astea cu cineva referitor la inlocuirea programului Adobe Photoshop cu Gimp, luind in consideratie la cit de costisitor e, o varianta gratis e oricind binevenita…what about Adobe Ilustrator?

  2. Alex
    Posted 1 ianuarie, 2009 at 11:18 pm | Permalink | Răspunde

    I have this problem:

    The following packages have unmet dependencies:
    gimp: Depends: libgimp2.0 (>= 2.6.3) but 2.4.5-1ubuntu2 is to be installed
    Depends: libgtk2.0-0 (>= 2.14.1) but 2.12.9-3ubuntu5 is to be installed
    Depends: libpango1.0-0 (>= 1.21.6) but 1.20.5-0ubuntu1 is to be installed
    Depends: libpoppler-glib3 but it is not installable

  3. Badan Sergiu
    Posted 5 ianuarie, 2009 at 4:18 pm | Permalink | Răspunde

    Firstly, what version of ubuntu are you using?
    You should do ok if you edit the /etc/apt/sources.list , and instead of „hardy” (if you use hardy) write „interpid”, then do „apt-get update”, then, I think, try one more time. Don’t forget to change the /etc/apt/sources.list to the initial state.

  4. Dave
    Posted 27 martie, 2009 at 8:23 pm | Permalink | Răspunde

    you mean „intrepid” not „interpid”

    I have the same problem, in hardy. getting the same dependency errors.
    any other ideas?

  5. Badan Sergiu
    Posted 27 martie, 2009 at 8:31 pm | Permalink | Răspunde

    Hi Dave.
    It really is intrepid , as you mentioned.
    At the time i wrote that comment, I was thinking that it’s interpid.
    Thank you for correcting me.

Lasă un răspuns

Completează mai jos detaliile tale sau dă clic pe un icon pentru a te autentifica:

Logo WordPress.com

Comentezi folosind contul tău WordPress.com. Dezautentificare /  Schimbă )

Fotografie Google

Comentezi folosind contul tău Google. Dezautentificare /  Schimbă )

Poză Twitter

Comentezi folosind contul tău Twitter. Dezautentificare /  Schimbă )

Fotografie Facebook

Comentezi folosind contul tău Facebook. Dezautentificare /  Schimbă )

Conectare la %s

%d blogeri au apreciat asta: